Brief scheduled maintenance – infrastructure upgrade
Resolved
Jul 15, 2026 at 8:20pm UTC
Maintenance ended
Affected services
Created
Jul 15, 2026 at 8:15pm UTC
Essencium will be briefly unavailable during scheduled maintenance. We're
moving to a custom domain and upgrading the platform's infrastructure to
make it faster and more reliable.
Expected downtime: 1–2 hours
During this window you may be unable to sign in or load content. All your
data stays safe — nothing is lost. Once we're done, everything will work
as usual, just a little smoother.
Thanks for your patience. If anything still misbehaves after the window
closes, let us know via the in-app feedback button.
Affected services